Tuesday, March 9, 2010

Installing SIPp 3.1 on Ubuntu 9.04

Open a command line terminal

$ sudo apt-get install ncurses-dev
$ sudo apt-get install build-essential

#Grab sipp 3.1 from sourceforge.net
$ wget -m -nd http://downloads.sourceforge.net/project/sipp/sipp/3.1/sipp.3.1.src.tar.gz

#extract it locally
$ tar -xzf sipp.3.1.src.tar.gz
$ cd sipp.svn

Open ./sipp.svn/scenario.hpp and add this line

#include <limits.h>


#include <sys/socket.h>

save the file, and in the terminal do


You're done ;-)

UPDATE : The latest unstable snapshot available from http://sipp.sourceforge.net/snapshots/sipp.2009-07-29.tar.gz does not have this problem and does not throw *segmentation fault* as sipp 3.1 does now on my ubuntu 10.04